In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Search found 339 matches

Go to advanced search

by Ingo Junge-Herrmann
Fri Nov 30, 2018 8:19 am
Forum: English
Topic: problem with BrowseForFolderDlg in Xailer 32
Replies: 3
Views: 624

Re: problem with BrowseForFolderDlg in Xailer 32

Hi Hurricane,

it's solved.

Thank you

Ingo
by Ingo Junge-Herrmann
Fri Nov 30, 2018 8:13 am
Forum: English
Topic: problem with BrowseForFolderDlg in Xailer 32
Replies: 3
Views: 624

Re: problem with BrowseForFolderDlg in Xailer 32

Hi Hurricane, thanks for replying. Here my Code METHOD OrdnerWahl( oSender, Value ) CLASS Eingangsliste LOCAL cPfad := "C:\Debeka\data\" LOCAL cPdfPfad := "" WITH OBJECT ::oBrowseForFolderDlg1 :cRoot := cPfad IF :Run() cPdfPfad := :cRoot ELSE cPdfPfad := "" ENDIF END WI...
by Ingo Junge-Herrmann
Thu Nov 29, 2018 1:09 pm
Forum: English
Topic: problem with BrowseForFolderDlg in Xailer 32
Replies: 3
Views: 624

problem with BrowseForFolderDlg in Xailer 32

Hi all,
there is a problem in BrowseForFolderDlg. Setting a path to :cRoot has no effect. Always starts with the Rootdirectory of the disk.
Is there a Workaround?

Thanks Ingo
by Ingo Junge-Herrmann
Tue Jul 24, 2018 10:55 am
Forum: English
Topic: OLE Automation object
Replies: 0
Views: 728

OLE Automation object

Hi, I'm using Word.Application as an OleObject. I don't know how to convert the Word-VBA-Method like "Selection.Find.Execute Replace:=1" to Xailer-Code. Any idea how to commit "Replace:=1" with the method "Execute"? here the example: oWord := CreateObject( "Word.Ap...
by Ingo Junge-Herrmann
Sat Jun 30, 2018 4:57 pm
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Re: Processmessages causes error

the Windows 10 Version on both machines is 1803 (Build 17134,112).

Hurricane I also read the posts of other developers. It's obviously a Windows 10 problem. Microsoft itself is silent.
Despite the error messages in IDE debug mode my app is still running fine.

Regards
Ingo
by Ingo Junge-Herrmann
Thu Jun 28, 2018 12:37 pm
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Re: Processmessages causes error

Hi Hurricane, Office versions are 32-bit 2007 and 2010 the calls are CreateObject( "Word.Application" ) CreateObject( "Outlook.Application" ) Both calls doesn't cause any error. The error messages are only on Windows 10. On Windows 7 no error occures. Therefore I think this have ...
by Ingo Junge-Herrmann
Wed Jun 27, 2018 9:54 am
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Re: Processmessages causes error

Hurricane, I'm using a modified class TForm. The line RETURN ::Super:Create( oParent ) causes the error windows\dwm\dwmapi\attribute.cpp(92)\dwmapi.dll!73003CF4: (caller: 73064839) ReturnHr(1) tid(242c) 80070006 Das Handle ist ungültig. Here the Code of the class CLASS TForm FROM XForm DATA cName IN...
by Ingo Junge-Herrmann
Wed Jun 27, 2018 8:47 am
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Re: Processmessages causes error

Hurrycane, yes I'm using Ocx as ActiveX and WORD and Outlook as OleObjects with the functions "CreatObject" or "GetActiveObject" of Xailer's WinOle.prg. I deactivated the ProcessMessages-Calls in my Code. The errors still exist. It's curious I have no errors if runnig the App in ...
by Ingo Junge-Herrmann
Tue Jun 26, 2018 7:49 am
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Re: Processmessages causes error

Hi Xailer team,
I tested it now with Xailer 5.12 (Demo). The same error Messages on Windows 10 32 bit and 64 bit. See my post before.
On Windows 7 aren't no error Messages.
It seems to be a Windows 10 Problem.

Can you fix it?

Regards

Ingo
by Ingo Junge-Herrmann
Tue Jun 26, 2018 5:29 am
Forum: English
Topic: Processmessages causes error
Replies: 9
Views: 1555

Processmessages causes error

Hi all, my apps built with Xailer 3.20 shows errors on Windows 10 in debug mode when Processmessages() is calling. They cöme from Xailers code because I don't call Processmessages in my Code. The app keeps still running. Here some error messages shown in the debug-window: windows\dwm\dwmapi\attribut...
by Ingo Junge-Herrmann
Wed Apr 03, 2013 1:36 pm
Forum: English
Topic: X3 memory leaks
Replies: 2
Views: 812

X3 memory leaks

Ignacio, thank you, there were some datasets only closed but not destroyed. Now there are other leaks shown: Block 1 08ba9758 (size 40) WMNOTIFY(0), " 50407806A864590968A88600010001000000000000000000287470060000 00000000000000000000 " Block 2 06784050 (size 40) WMNOTIFY(0), " 483B1209589...
by Ingo Junge-Herrmann
Wed Apr 03, 2013 12:39 pm
Forum: English
Topic: X3 memory leaks
Replies: 2
Views: 812

X3 memory leaks

Hi all, my project shows many memory leaks like this: Block 1 04a0b8f8 (size 896) XA_WLCREATE(0), " 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 000000000000000000000000000000000000000000000000000000000000 0000000000000...
by Ingo Junge-Herrmann
Fri Mar 29, 2013 8:16 am
Forum: English
Topic: X3 IsDir()?
Replies: 2
Views: 1044

X3 IsDir()?

Thanks José,
that's it.
Regards and Happy Easter
Ingo
"José Lalí­n" <joselalinf@gmail.com> schrieb im Newsbeitrag
news:51546de1$1@svctag-j7w3v3j....
> Ingo,
>
> try with ExistDir()
>
> Regards,
> José Lalí­n
>
by Ingo Junge-Herrmann
Wed Mar 27, 2013 7:08 am
Forum: English
Topic: X3 with xHarbour and BCC++
Replies: 4
Views: 1753

X3 with xHarbour and BCC++

Jose,
thank you for the reply.
But I want to use XHARBOUR not HARBOUR!
Is it possible with X3?
TIA
Regards
Ingo
by Ingo Junge-Herrmann
Tue Mar 26, 2013 11:07 am
Forum: English
Topic: X3 with xHarbour and BCC++
Replies: 4
Views: 1753

X3 with xHarbour and BCC++

Hi, to use xHarbour and BCC++ I set in Extra > Options > Harbour the directory to the xHarbour-folder I installed it The project-Option BCC++ ist marked. Recompiling my project with xHarbour and BCC++ I got the error message: Fatal: Unable to open file 'HBEXTERN.LIB' 151 Files, 0 Warnings, 1...
by Ingo Junge-Herrmann
Tue Mar 26, 2013 10:46 am
Forum: English
Topic: X301 and MinGW
Replies: 2
Views: 1124

X301 and MinGW

Jose,
thank you.
Regards
Ingo
by Ingo Junge-Herrmann
Mon Mar 25, 2013 6:08 pm
Forum: English
Topic: X301 and MinGW
Replies: 2
Views: 1124

X301 and MinGW

Hi, building the sample DBFData6 with mingw I get the error below Linke: DBFData6.exe... C:MinGWBinld: cannot find C:/MinGW/Lib/gcc/mingw32/4.7.1-dw2/crtbegin.o: No such file or directory C:MinGWBinld: cannot find -lgcc 0 Files, 0 Warnings, 2 Errors Kompilierzeit: 0.00s Linkzeit: 0.84s Gesamtzeit: 0...
by Ingo Junge-Herrmann
Tue Mar 19, 2013 5:05 pm
Forum: English
Topic: X3 IsDir()?
Replies: 2
Views: 1044

X3 IsDir()?

Hi, is in Harbour a function corresponding to xH's IsDir()? C:/MW35/Obj/MWDBF.do:MWDBF.c:(.data+0x8e8): undefined reference to `HB_FUN_ISDIR' C:/MW35/Obj/MWWord.do:MWWord.c:(.data+0x488): undefined reference to `HB_FUN_ISDIR' C:/MW35/Obj/MWMP1Reg.do:MWMP1Reg.c:(.data+0x1c78): undefined reference to ...
by Ingo Junge-Herrmann
Sat Jul 21, 2007 7:26 am
Forum: English
Topic: Using external library
Replies: 2
Views: 885

Using external library

Frank, use in the IDE the "Project - add file to project" menu option. In the standard dialog use "all files (*.*)". Take a look at the IDE-help in chapter "Projects">"Add files to the project". Ingo "Frank Verlinde" < frank.verlinde@skynet.be >...
by Ingo Junge-Herrmann
Mon Jul 02, 2007 7:17 pm
Forum: English
Topic: How to login in Xailers private newsgroup
Replies: 1
Views: 795

How to login in Xailers private newsgroup

I'm a registered user.
Why I can nomore login like before?
Ingo
info@mandantwin.com
by Ingo Junge-Herrmann
Fri Mar 16, 2007 6:06 pm
Forum: English
Topic: Menu problem
Replies: 4
Views: 1109

Menu problem

Hallo Xailers, to qualify the menu problem: the items in the menuline ignore the "&" A (very small) problem have I with the oMDIMenu. The list of the open MDIChilds don't have the same style as the menuitems above. Please take a look at the attached sample. Regards Ingo -- Attached files MD...
by Ingo Junge-Herrmann
Fri Mar 16, 2007 6:06 pm
Forum: English
Topic: Menu problem
Replies: 4
Views: 1109

Menu problem

Hallo Xailers, to qualify the menu problem: the items in the menuline ignore the "&" A (very small) problem have I with the oMDIMenu. The list of the open MDIChilds don't have the same style as the menuitems above. Please take a look at the attached sample. Regards Ingo -- Attached files MD...
by Ingo Junge-Herrmann
Fri Mar 16, 2007 5:20 pm
Forum: English
Topic: Menu problem
Replies: 4
Views: 1109

Menu problem

Hallo Xailers, when the menu of a form is built by code then the underlined letter (marked with "&" like in "&save as") is shown correctly. If the menu is built in the IDE no underlined letter will be shown. Not in the IDE and not at application runtime. What to do? Thanks in advance...
by Ingo Junge-Herrmann
Fri Mar 16, 2007 5:20 pm
Forum: English
Topic: Menu problem
Replies: 0
Views: 2690

Menu problem

Hallo Xailers, when the menu of a form is built by code then the underlined letter (marked with "&" like in "&save as") is shown correctly. If the menu is built in the IDE no underlined letter will be shown. Not in the IDE and not at application runtime. What to do? Thanks in advance...
by Ingo Junge-Herrmann
Wed Mar 14, 2007 9:20 am
Forum: English
Topic: Resources linking problem seems to be fixed
Replies: 0
Views: 2683

Resources linking problem seems to be fixed

Jose, after I installed version 1.3 the posted problem - you remember - never poped up. Regards Ingo "Jose F. Gimenez" <jfgimenez@wanadoo.es> wrote: >Ingo, > >> I got more and more problems with compiling the resources. >> Klicking in the IDE on the button for...

Go to advanced search