In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Search found 396 matches

Go to advanced search

by bingen
Wed May 27, 2015 12:04 pm
Forum: Spanish
Topic: Problema al ordenar controles de un Form
Replies: 2
Views: 855

Problema al ordenar controles de un Form

Buenas XTeam. Ordenar los controles en el IDE es una maravilla, para mi es lo mejor del IDE en mucho tiempo ya que ahorra muchísimo trabajo, pero causa un problema. Lo deseable sería que ordenara los controles del objeto contenedor sobre el que has pulsado botón derecho Ordenar controles , ya que ah...
by bingen
Wed May 27, 2015 11:59 am
Forum: Spanish
Topic: Tema Windows
Replies: 1
Views: 910

Re: Tema Windows

Dependiendo del tema la ventana activa y las demás no tienen por que tener el mismo color para el título, son definibles por separado.
by bingen
Thu May 21, 2015 2:24 pm
Forum: Spanish
Topic: CEF Browser con Xalir 4 no funciona?
Replies: 2
Views: 1340

Re: CEF Browser con Xalir 4 no funciona?

Muchas gracias, con esto funciona y de momento me arreglo así.

Salu2.
by bingen
Thu May 21, 2015 1:25 pm
Forum: FastReport
Topic: Una pregunta sobre añadir variables
Replies: 2
Views: 1347

Re: Una pregunta sobre añadir variables

Gracias Ignacio pero ni de una manera ni de otra, aunque he encontrado el por que y su solución, te cuento. Esto es una cosa inexplicable para mi que siempre ha tenido FR, no digo que sea un error pero de alguna manera te puede volver loco. Dentro del archivo FR3 en la segunda línea o bloque XML hay...
by bingen
Thu May 21, 2015 12:05 pm
Forum: Spanish
Topic: Tamaño maximo de Imagenes en Botones?
Replies: 2
Views: 832

Re: Tamaño maximo de Imagenes en Botones?

Prueba a poner en las propiedades nBmpHeigth y nBmpWidht 90 y 90

Salu2.
by bingen
Wed May 20, 2015 8:54 am
Forum: Spanish
Topic: CEF Browser con Xalir 4 no funciona?
Replies: 2
Views: 1340

CEF Browser con Xalir 4 no funciona?

Buenos días xTeam sigo recompilando mis proyectos con elnuevo Xailer y sorpresa, no dfuncionan los formularios que incluyen un CEF Browser.

He tomado el Samples CEF de Xailer y tampoco, da un GPF, han cambiado librerías o algo hago mal?

Error.jpg
Error.jpg (20.12 KiB) Viewed 1340 times

Gracias
by bingen
Tue May 19, 2015 6:30 pm
Forum: Spanish
Topic: Problema importante con Xailer 4.0.1
Replies: 1
Views: 588

Re: Problema importante con Xailer 4.0.1

PERDÓN CULPA MÍA NO HAY NINGÚN PROBLEMA EN XAILER Increíblemente se me colo en el panel que soporta ese botón que en el OnClick hiciera lo mismo que el OnClick del botón, así que cuando no estaba el botón o estaba en gris hacia lo que el panel y era casualidad lo mismo. :roll: Una torpeza inexcusabl...
by bingen
Tue May 19, 2015 6:02 pm
Forum: FastReport
Topic: Una pregunta sobre añadir variables
Replies: 2
Views: 1347

Una pregunta sobre añadir variables

Hola Ignacio, en mi código hago esto ::AddCategory("Variables de la aplicación") ::AddVariable("HeadLine2", ::cHeadLine2) ::AddVariable("HeadLine3", ::cHeadLine3) ::AddVariable("UserName", GetUserName()) ::AddVariable("ComputerName", GetComputerName(...
by bingen
Tue May 19, 2015 4:40 pm
Forum: FastReport
Topic: Problema con AddArray
Replies: 4
Views: 1229

Re: Problema con AddArray

Gracias Ignacio, así que recordaba haberlo usado y me funcionó en algún tiempo. Lo que planteas de pasarle un DbStruct es tedioso sobre todo si hay que hacerlo con el tipo, tamaño y decimales como he comprobado, aunque le he puesto todos los tamaños y decimales a cero y sale andando también. Lo más ...
by bingen
Tue May 19, 2015 4:29 pm
Forum: FastReport
Topic: GPF en algunos FR3
Replies: 3
Views: 1246

Re: GPF en algunos FR3

Si así lo he hecho uno a uno en los que me ha dado el GPF, no es problema vuestro. Pasaba a veces al grabar en el viejo FR3 de Sergey, lo que pasa que en su caso al cargar el reporte no daba error, todo iba bien y solo te dabas cuenta por que no te dejaba añadir variables si lo necesitabas ya que el...
by bingen
Tue May 19, 2015 12:27 pm
Forum: FastReport
Topic: CallHBFunc sin parámetros
Replies: 4
Views: 1773

Re: CallHBFunc sin parámetros

Gracias Ignacio espero que lo consigais pero entre tanto dejo el CallHbFunc aunque tampoco es tan complicado [EvalMacro('NetName(.t.)')]

Salu2
by bingen
Tue May 19, 2015 12:25 pm
Forum: FastReport
Topic: GPF en algunos FR3
Replies: 3
Views: 1246

Re: GPF en algunos FR3

Como me imaginaba es una cochinada que a veces mete el viejo FR en el FR3 en el parámetro PropData como puede verse en el ejemplo adjunto, , pero en el nuevo FR pega el GPF. Borro el propdata completo y se arregla. <?xml version="1.0" encoding="utf-8"?> <TfrxReport Version="...
by bingen
Tue May 19, 2015 12:14 pm
Forum: FastReport
Topic: GPF en algunos FR3
Replies: 3
Views: 1246

GPF en algunos FR3

En bastantes de los FR3 que tengo al pasar al nuevo FR me da directamente este GPF al intentar cargar el FR3, probablemente sea un error en el interior del FR3 anterior pero no se si podéis darme más luz al asunto
Error_3.jpg
Error_3.jpg (44.26 KiB) Viewed 1246 times


Gracias.
by bingen
Tue May 19, 2015 11:58 am
Forum: FastReport
Topic: Problema con AddArray
Replies: 4
Views: 1229

Re: Problema con AddArray

Perdón no me había fijado las fechas si salen los números nada de nada
by bingen
Tue May 19, 2015 10:45 am
Forum: FastReport
Topic: Problema con AddArray
Replies: 4
Views: 1229

Problema con AddArray

Estoy probando docenas de informes que tenía hechos con FR y me acabo de encontrar con una curiosidad, un informe pierde casi todos los datos que antes pasaba con un setarray() Ahora uso un AddArray para enviar un array a FR con estos datos de ejemplo aDatos:={{1,"Pepe","Cuenta",...
by bingen
Tue May 19, 2015 9:28 am
Forum: FastReport
Topic: CallHBFunc sin parámetros
Replies: 4
Views: 1773

Re: CallHBFunc sin parámetros

Gracias Ignacio, eso es precisamente lo que quería, pasar para siempre del CallHBFunc, pero no recordaba como se hacía en el nuevo FastReport, ya que estuve probando como tu dices y no me funciona, me explico. [Time()] o [Date()] si que funcionan, pero por ejemplo empecé probando con [NetName(.T.)] ...
by bingen
Tue May 19, 2015 9:02 am
Forum: Spanish
Topic: Increible locura con Val( )
Replies: 7
Views: 927

Re: Increible locura con Val( )

Eso es exactamente lo que necesitaba, hacia un ToString y con Str se ha solucionado. Lo siento Ignacio pero no se trataba de comparar nada, eso si que funciona como tu dices, sino de presentar el valor en pantalla al cliente y el cliente sorprendido no acababa de entender que es el sistema de coma f...
by bingen
Tue May 19, 2015 8:57 am
Forum: Spanish
Topic: Problema importante con Xailer 4.0.1
Replies: 1
Views: 588

Problema importante con Xailer 4.0.1

Buenos días XTeam, me acabo de encontrar con una "sorpresa muy preocupante" al recompilar mis aplicaciones con X401 (no se si antes pasaba), tengo un panel lateral con unos BtnBmp y en concreto un BtnBmp al que le hago en el OnShow del Form un lEnabled := .F. y efectivamente se queda en gr...
by bingen
Mon May 18, 2015 8:26 am
Forum: FastReport
Topic: CallHBFunc sin parámetros
Replies: 4
Views: 1773

CallHBFunc sin parámetros

Buenos días xTeam. Me encuentro con que CallHBFunc('ReportLogo') sin parámetros ya que la función no los necesita me da un error de que CallHbFunc no tiene parámetros y me veo obligado a efectura la tontería de CallHBFunc('ReportLogo',['']) para que funcione. Creí entender que ya funcionaba sin pará...
by bingen
Mon May 18, 2015 8:22 am
Forum: Spanish
Topic: Increible locura con Val( )
Replies: 7
Views: 927

Re: Increible locura con Val( )

Gracias Ignacio, lo que nos propones es exactamente lo que estamos haciendo ahora multiplicando por múltiplos de 100, tomar la parte entera y dividir por 100, pero hay unos valores que ni así salen bien. MsgInfo(Int(8.888888888888889*100)) --> 888 MsgInfo(Int(8.888888888888889*100)/100) --> 8.880000...
by bingen
Sun May 17, 2015 10:24 am
Forum: Spanish
Topic: Increible locura con Val( )
Replies: 7
Views: 927

Re: Increible locura con Val( )

Interesante artículo. Ya tenía claro que en las operaciones se utilizaba la coma flotante, pero si no se hace ninguna operación y si solo quiero mostrar un valor es casi ridículo. Por ejemplo obtengo unos valores que quiero presentar con un Round(nValor,2) MsgInfo(Round(10.8974358974359,2)) MsgInfo(...
by bingen
Tue May 12, 2015 6:34 pm
Forum: Spanish
Topic: Increible locura con Val( )
Replies: 7
Views: 927

Increible locura con Val( )

Vamos a ver que le pasa a Harbour con esto LogDebug(Val("6.55")) LogDebug(Val("7.55")) LogDebug(Val("8.55")) LogDebug(Val("9.55")) Y el resultado es #16: 6.55 #17: 7.55 #18: 8.550000000000001 #19: 9.550000000000001 De que chistera saca este conejo???? Salu2.
by bingen
Thu Apr 16, 2015 3:29 pm
Forum: Spanish
Topic: Problemas con el MultiHilo
Replies: 2
Views: 501

Problemas con el MultiHilo

Me acabo de dar cuenta de que en la aplicación que si funciona la librerí­a está en negrita ¿?¿? y que esto pasa cuando se pulsa doble click sobre ella. He ido a las otras app y lo he hecho así­ y ahora funciona. Perdón por mi ignorancia pero que es esa negrita???? Se linka antes por ejemplo?? Salu2.
by bingen
Thu Apr 16, 2015 3:23 pm
Forum: Spanish
Topic: Problemas con el MultiHilo
Replies: 2
Views: 501

Problemas con el MultiHilo

Hola XTeam, he programado por primera vez un segundo Hilo y ha funcionado correctamente y ahora lo voy a implementar en todas mis aplicaciones. En la primera todo OK. Pero en todas las demás me dice esto a pesar de que SI HE linkado la librerí­a hbvmmt #1: Error: Multithread libraries not linked! Th...
by bingen
Wed Apr 15, 2015 4:42 pm
Forum: Spanish
Topic: Foro Web
Replies: 1
Views: 539

Foro Web

Ha estado funcionando erróneamente un tiempo debido al cambio de servidor y ahora ya funciona bien.

Go to advanced search