Page 1 of 1

Errores utilizando xEdit

Posted: Tue Sep 29, 2015 6:12 pm
by jvtecheto
Buenas tardes:

Hoy de repente, me aparecen un monton de errores al compilar un proyecto simplísimo en el xEdit. :oops:

Enlazando HolaMundo.exe...
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbextern
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbdebug
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbvm
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbrtl
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhblang
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbcpage
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lgtwin
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbrdd
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbuddall
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbusrrdd
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lrddntx
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lrddcdx
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lrddnsx
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lrddfpt
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbhsx
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbsix
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbmacro
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbcplr
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbpp
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbcommon
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbmainwin
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbmxml
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lmxml
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbpcre
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbwin
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbmzip
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lminizip
C:\Xailer\hb32\comp\mingw\Bin\ld: cannot find -lhbzlib
0 Files, 0 Warnings, 28 Errors
Tiempo de compilación: 0.00s Tiempo de enlazado: 0.61s Tiempo total: 0.61s

¿Ideas?

Gracias por la ayuda.

Jose Vte.

Re: Errores utilizando xEdit

Posted: Tue Sep 29, 2015 6:56 pm
by jfgimenez
José Vte,
todas esas son librerías de Harbour. Es posible que no esté bien puesto el path al directorio lib de Harbour, y por eso no encuentra las librerías. O quizás estás usando una versión de Harbour para BCC que no tiene las librerías para MinGW. En este último caso, descarga nuestros binarios de Harbour desde http://www.xailer.com/download?file=2

Re: Errores utilizando xEdit

Posted: Tue Sep 29, 2015 7:13 pm
by jvtecheto
Gracias Jose:

Eso era..., eso pasa por tocar la configuración y no fijarse bien. Perdon por la molestia. :oops:

Saludos.

Jose Vte.