Page 1 of 1

Detalles en xaDBU

Posted: Fri Apr 12, 2019 4:35 pm
by ddupre
Ignacio,
Estoy realizando pruebas con mi licencia de xaDBU y encuentro algunos detalles, no se si es por mal uso o son pequeños bugs.

Utilizo archivos DBF e índices NTX

1) Abro una tabla, luego abro varios idices (no importa la cantidad), veo que se carga el combobox que permite seleccionar el orden, selecciono uno a uno los diferentes ídices y veo reflejado el orden en el browse, luego cierro todos los indices con la opción del menu "Indices->cerrar indices", finalmente abro otros indices o los mismos que cerré y ya no se actualiza el combobox y tampoco quedan abiertos dichos indices.

2) Exportando algunos DBF a Excel (no logro darme cuenta en qué casos), aparece este error:
***************************** Registro de errores *****************************

Exe: c:\xaDbu\xaDbu.exe
Version: 2.0.0.0
User name: Administrador
Computer name: DANIEL
Fecha: 12/04/19
Hora: 11:30:19
Memoria libre: 861148
Area actual: 1

------------------------- Información del compilador --------------------------

Versión Xailer: Xailer 6.1.0
Compilador: Harbour 3.2.0dev (r1803161710)
Compilador C/C++: MinGW GNU C 7.3 (32-bit)
Plataforma: Windows 7 6.1 SP1

----------------------- Información detallada del error -----------------------

Subsistema: WINOLE
Código de error: 1007
Estado: .F.
Descripción: (0x80020005)
Operación: COLUMNS
Argumentos: [ 1] = Tipo: C Valor: [
Fichero:
Código error SO: -2147352567

Pila de llamadas:
WIN_OLEAUTO:COLUMNS (0)
TBROWSE:TOEXCEL (3615)
TDBBROWSE:TOEXCEL (1481)
(b)TFRMDBFVIEW (85)
TFRMDBFVIEW:TOEXCEL (0)
TFRMDBFVIEW:BTNEXCELCLICK (1430)
TTOOLBUTTON:ONCLICK (0)
(b)XTOOLBUTTON (41)
TTOOLBUTTON:CLICK (0)
TTOOLBAR:COMMAND (404)
TREBAR:WMCOMMAND (275)
RUNFORM (0)
TAPPLICATION:RUN (289)
MAIN (18)

------------------ Información detallada de áreas de trabajo ------------------

Area: 1
Alias: ARTICULO0
Registro: 1
Filtro:
Relación:
Orden del índice: 0
Clave activa: 0

Saludos
Daniel

Re: Detalles en xaDBU

Posted: Mon Apr 15, 2019 1:07 pm
by ignacio
Buenos días,

Adjunto vídeo en el que se comprueba que funciona correctamente:



En cuanto al segundo error, parece ser un error de gestión del propio control OLE. Si nos manda el archivo podemos hacer alguna prueba.

Un saludo

Re: Detalles en xaDBU

Posted: Mon Apr 15, 2019 4:16 pm
by ddupre
Ignacio,
Gracias por su respuesta,
En el adjunto le envío un DBF que provoca el error comentado.

Saludos
Daniel

Re: Detalles en xaDBU

Posted: Mon Apr 15, 2019 6:03 pm
by ignacio
Buenos días Daniel,

Efectivamente estaba fallando con tablas con muchas columnas. Acabamos de subir una nueva versión con el problema resuelto. Muchas gracias.

https://www.ozs.es/wp/xadbu/

Un saludo

Re: Detalles en xaDBU

Posted: Wed Apr 17, 2019 3:32 am
by ddupre
Ignacio,
Muchas gracias

Saludos