In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Xailer 5 TSharedModule

Foro de Xailer profesional en español
User avatar
bingen
Posts: 397
Joined: Mon Jul 07, 2014 8:17 pm
Location: Bilbao
Contact:

Xailer 5 TSharedModule

Postby bingen » Thu Aug 24, 2017 8:54 am

Estoy probando el SharedModule y veo una cosa curiosa, tras cambiar en el inspector de objetos los nombres de los objetos insertados en un TSharedModule no cambian los nombres en la ventana del SharedModule, adjunto imagen.
SharedModule.png
SharedModule.png (6.99 KiB) Viewed 1027 times


También podría haber un botón para un Nuevo SharedModule junto a Nuevo formulario y Nuevo módulo, aunque aparece bién en el menú del botón Nuevo.

He encontrado también un error de manera involuntaria. Si voy a un Form y añado desde Sistema un objeto oSharedModule y no le pongo nada en el cClassName (por olvido) voy a un control del Form como un oDbBrowse y empieza a dar el siguiente error como 50 veces hasta que se bloquea el IDE que no se puede cerrar salvo desde el administrador de tareas de Windows.
Error.jpg
Error.jpg (14.92 KiB) Viewed 1024 times


Gracias.
BiSoft Desarrollo de software profesional
http://www.bisoft.es
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xailer 5 TSharedModule

Postby jfgimenez » Sun Aug 27, 2017 10:25 pm

Bingen,

ese problema ocurría con Xailer 5.0.0, pero se corrigió en Xailer 5.0.1. Por favor, asegúrte de que lo has actualizado.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
bingen
Posts: 397
Joined: Mon Jul 07, 2014 8:17 pm
Location: Bilbao
Contact:

Re: Xailer 5 TSharedModule

Postby bingen » Mon Aug 28, 2017 10:05 am

Está actualizado a la 5.0.1 pero aún así lo he vuelto a instalar por si acaso y lo siento, el comportamiento es errático, da ese error y bloquea el IDE con frecuencia.

He metido los .o que pusiste en el foro y nada de nada, con ellos y sin ellos da lo mismo.

Que mas puedo probar?

Gracias.
BiSoft Desarrollo de software profesional
http://www.bisoft.es
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xailer 5 TSharedModule

Postby jfgimenez » Tue Aug 29, 2017 6:50 pm

Bingen,

lo acabo de probar de nuevo por si acaso, y los nombres de los componentes se cambian correctamente. Tanto en el treeview de controles del inspector, como en el formulario de edición del sharedmodule como en la declaración COMPONENT en el editor de código. Vamos, todo correcto.

Lo de los .o sólo afecta a las aplicaciones finales, no al IDE.

En fin, no sé qué te puede estar pasando. Si puedes, prueba a renombrar la carpeta actual de Xailer y volver a instalarlo, por si te quedara algo que no deba estar ahí.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info

Return to “Spanish”