In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

BUG IDE 5 en Nuevo Formulario o Modulo

Foro de Xailer profesional en español
User avatar
gerencia
Posts: 229
Joined: Sat Jun 20, 2009 6:01 pm

BUG IDE 5 en Nuevo Formulario o Modulo

Postby gerencia » Fri Sep 01, 2017 10:51 pm

Ignacio,

Al crear un nuevo formulario o un modulo(Boton nuevo formulario o nuevo modulo) el ide marca la pestaña del editor "Form2.prg" en negro, y NO lo toma
como si fuese un formulario o modulo nuevo,al cerrar este en la x de la pestaña(no pregunta que si quieres cerrar,asume que esta grabado) y no lo retira
del tree del proyecto.

generando un error de compilacion.

Que no exite Form2.prg
Jose David Angulo Urzola
Auditoria y Sistemas Ltda.
Cartagena-Colombia
josemanuelserrano
Posts: 9
Joined: Thu Jul 23, 2015 3:23 pm
Location: Tres Cantos - Madrid
Contact:

Re: BUG IDE 5 en Nuevo Formulario o Modulo

Postby josemanuelserrano » Sat Sep 02, 2017 9:40 am

A mí me pasa lo siguiente:

- Creo un proyecto nuevo vacío
- Pulso botón "nuevo formulario", y crea Form1.prg, quedándose en rojo en la pestaña del "Editor de código"
- Pulso botón "nuevo formulario", y crea Form2.prg y cierro el formulario y en la pestaña del "Editor de código" lo cierro también respondiendo que no quiero guardarlo.

Automáticamente Form1.prg me cambia de estado como si estuviese guardado.

Si intento compilar me muestra un error:
Compilando Pruebas.prg...
Compilando Form1.prg...
Cannot open Form1.prg, assumed external
2 Files, 0 Warnings, 1 Errors
Tiempo de compilación: 0.19s Tiempo de enlazado: 0s Tiempo total: 0.19s


Saludos
José Manuel
ProSer Informática, SL
http://www.proserinformatica.com
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: BUG IDE 5 en Nuevo Formulario o Modulo

Postby jfgimenez » Thu Sep 07, 2017 8:06 pm

José David, José Manuel,

Ya lo hemos corregido. Gracias por la información.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
gerencia
Posts: 229
Joined: Sat Jun 20, 2009 6:01 pm

Re: BUG IDE 5 en Nuevo Formulario o Modulo

Postby gerencia » Thu Sep 07, 2017 10:04 pm

Gracias José,

Cuando tendremos estas mejoras. ?

Saludos,
Jose David Angulo Urzola
Auditoria y Sistemas Ltda.
Cartagena-Colombia
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: BUG IDE 5 en Nuevo Formulario o Modulo

Postby jfgimenez » Mon Sep 11, 2017 8:34 pm

José David,

en breve, seguramente esta misma semana, publicaremos la nueva versión.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
gerencia
Posts: 229
Joined: Sat Jun 20, 2009 6:01 pm

Re: BUG IDE 5 en Nuevo Formulario o Modulo

Postby gerencia » Fri Sep 15, 2017 2:56 pm

Hola José,

Continua presentando el error del IDE con en nuevo Formulario en la nueva versión(5.0.2).

Saludos,
Jose David Angulo Urzola
Auditoria y Sistemas Ltda.
Cartagena-Colombia

Return to “Spanish”