In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

ERROR AL COMPILAR

Foro de Xailer profesional en español
User avatar
EOI Elche
Posts: 7
Joined: Wed Jan 23, 2019 10:28 am

ERROR AL COMPILAR

Postby EOI Elche » Sat May 18, 2019 11:02 am

De la noche a la mañana mi versión de Xailer5 me da el siguiente mensaje de error al compilar.

Enlazando FACTUBAR.exe...
C:\XAILER5\Hb32\comp\mingw\Bin\ld: cannot find C:/XAILER5/Hb32/comp/mingw/Lib/gcc/i686-w64-mingw32/7.3.0/crtbegin.o: No such file or directory
C:\XAILER5\Hb32\comp\mingw\Bin\ld: cannot find -lgcc_eh
0 Files, 0 Warnings, 2 Errors
Tiempo de compilación: 0.00s Tiempo de enlazado: 0.60s Tiempo total: 1.40s

Si me podéis ayudar lo antes posible os lo agradecería, tengo que instalar algunas modificaciones del el lunes a primera hora y me estoy volviendo loco.
Hace un par de días no daba este mensaje, no sé que ha podido pasar.

Gracias
User avatar
EOI Elche
Posts: 7
Joined: Wed Jan 23, 2019 10:28 am

Re: ERROR AL COMPILAR

Postby EOI Elche » Sat May 18, 2019 11:18 am

Acabo de encontrar la solución en el foro:

prueba a cambiar el compilador de C en las propiedades del proyecto. Es decir, si quieres usar BCC, entonces cambia a MinGW y pulsa Aceptar. Después vuelve a entrar y lo cambias de nuevo. Y si quieres MinGW, pues lo haces al revés.

De todas formas y por curiosidad ¿alguien sabe por que de pronto me ha dado el mensaje de error anterior?

Gracias.
User avatar
ignacio
Site Admin
Posts: 8550
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: ERROR AL COMPILAR

Postby ignacio » Mon May 20, 2019 4:43 pm

Hola,

El proceso que has realizado, no hace más que establecer los valores por defecto de compilación y enlazado. Por algún motivo no eran los correctos.

Un saludo
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info

Return to “Spanish”