In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Problema TImage

Foro de Xailer profesional en español
josemanuelserrano
Posts: 9
Joined: Thu Jul 23, 2015 3:23 pm
Location: Tres Cantos - Madrid
Contact:

Problema TImage

Postby josemanuelserrano » Sat Sep 02, 2017 9:26 am

Buenos días

Si en una ventana incorporo un TImage, y le indico que la imagen es un JPG desde recurso, en caso que la imagen sea mayor que el tamaño en la ventana, si le indico lAutoFit := .T., en diseño funciona, pero cuando compilo el programa y lo ejecuto, no hace caso y no escala la imagen, viéndose esta parcialmente

Saludos
José Manuel
ProSer Informática, SL
http://www.proserinformatica.com
User avatar
ignacio
Site Admin
Posts: 8574
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: Problema TImage

Postby ignacio » Sat Sep 02, 2017 5:15 pm

Hola José Manuel,

No consigo reproducir tu error, lo siento. A ver si puedes mandar un ejemplo. Gracias.

Un saludo
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Problema TImage

Postby jfgimenez » Thu Sep 07, 2017 8:27 pm

José Manuel,

supongo que el problema te ha surgido en una "beta" que te haya enviado Ignacio. Si es así, ya está corregido.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info

Return to “Spanish”