In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Xedit - problema al compilar con RC

Foro público de Xailer en español
joseluissanchez
Posts: 2
Joined: Wed Apr 10, 2019 8:23 pm

Xedit - problema al compilar con RC

Postby joseluissanchez » Sat Apr 13, 2019 6:04 pm

Hola a todos,
estoy comenzando a usar Xedit, la incorporación del depurador para GUI me ha convencido y la verdad es que es un editor fantástico. He creado un proyecto y lo puedo compilar sin problemas:

Image

El problema está cuando le añado un archivo de recursos. Entonces ya no puedo compilar el programa y me aparece el siguiente error:

Image

El fichero RC lo tengo en la carpeta de Recursos que tiene definido el proyecto, pero cuando meto el fichero RC al reconstruir el proyecto ya no me genera el EXE, cosa que sin fichero RC sí lo hace.

¿ Alguien tiene idea de qué puede estar pasando ?

Saludos,
José Luis Sánchez
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xedit - problema al compilar con RC

Postby jfgimenez » Thu May 02, 2019 8:25 pm

José Luis,

¿pudiste solucionar el problema?
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
jvtecheto
Posts: 123
Joined: Thu Dec 19, 2013 1:18 pm

Re: Xedit - problema al compilar con RC

Postby jvtecheto » Wed May 15, 2019 5:29 pm

Hola Jose:

Pues yo tengo el mismo problema que Jose Luis.

Creo que el xEdit falla al incluir el .rc

Me da el siguiente error.

Compilando Asoc.rc...
Error Asoc.rc 5 11: Cannot open file: winresrc.h
1 Files, 0 Warnings, 1 Errors
Tiempo de compilación: 0.09s Tiempo de enlazado: 0s Tiempo total: 0.09s

El rc es muy simple.

y para compilar el .rc utilizo.
C:\BCC73\BIN\brc32.exe con la opcion -r

Saludos.

Jose Vte.
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xedit - problema al compilar con RC

Postby jfgimenez » Wed May 15, 2019 8:15 pm

José Vicente,

ahora sí. Con el mensaje de error que has puesto creo que ya entiendo lo que está pasando: el problema son los #include

No sé exactamente el porqué estáis usando #include dentro de un .rc; en Xailer nunca lo hemos necesitado. En cualquier caso, por el mensaje de error está claro que no encuentra el fichero winresrc.h. Por favor, prueba estas dos opciones:

1) Quita los #include del fichero .rc. Si los necesitas porque estés usando alguna constante, entonces esto no te vale.

2) Prueba a añadir el <path> donde están los .h en el "entorno de programación". Tienes que ir a la pestaña "compilador de recursos" y seleccionar "usar el siguiente compilador". Busca el fichero brc32.exe, y en "opciones de compilación" por esto (sin las comillas y sustituyendo <path> por la ruta real donde tengas los .h): "-r -i<path> -fo%FO %FI". Tendría que quedar así:

Image204.jpg
Image204.jpg (34.51 KiB) Viewed 515 times


Si con 2) funciona, entonces haremos la modificación en XEdit para que le pase el path automáticamente al compilar con brc32.

Gracias por tu ayuda.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
jvtecheto
Posts: 123
Joined: Thu Dec 19, 2013 1:18 pm

Re: Xedit - problema al compilar con RC

Postby jvtecheto » Thu May 16, 2019 8:06 pm

jfgimenez wrote:José Vicente,

2) Prueba a añadir el <path> donde están los .h en el "entorno de programación". Tienes que ir a la pestaña "compilador de recursos" y seleccionar "usar el siguiente compilador". Busca el fichero brc32.exe, y en "opciones de compilación" por esto (sin las comillas y sustituyendo <path> por la ruta real donde tengas los .h): "-r -i<path> -fo%FO %FI". Tendría que quedar así:


Esta es la opción buena Jose, Muchas gracias, por cierto ya que estamos con el XEdit te comunico lo que yo creo que es un bug que lanza Warning cuando las
rutas estan bien configuradas.

Warning W8123: Path 'C:\Users\José Vte. Cheto\Documents\Harbour\Projects\PruebasGUI\Include' not found - path ignored in option '-I'

Pero te deja compilar.

También me hace una cosa rarísima cuando miro mucho las configuraciones en el fichero de configuración me graba 1000 veces, aprox. la ruta del fichero de ayuda y
al arrancar me tarda muchísimo, claro sino tocamos la configuración no lo hace claro.

Son los dos problemillas que he descubierto por lo demás un IDE fantástico y que mas podemos pedir si es gratis.

Os doy las gracias por vuestro aporte.

Saludos.

Jose.

Return to “Spanish”