In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Xailer 5.03 .... Compile error on all projects??

Xailer professional forum in English
ChrisGillard
Posts: 384
Joined: Tue May 01, 2007 5:49 pm

Xailer 5.03 .... Compile error on all projects??

Postby ChrisGillard » Thu Mar 29, 2018 9:22 pm

Hi,

I am using my Xailer 5.03 for the first time for maybe 3 or 4 months .... none of my projects will compile with the following error to the screen.

I have deleted all project objs and doing a BUILD

This project is a test and is new with one form and Hello World label ... this is the error

I have some urgent changes to do to a project so I would like your thoughts.

Nothing much has happened to my PC, Windows 10, 3 or 4 months of Microsoft updates and usual installs and uninstalls.

Thanks

Chris

[img]
29-03-2018%2020-14-26.png
[/img]
Attachments
29-03-2018 20-14-26.png
29-03-2018 20-14-26.png (10.16 KiB) Viewed 629 times
User avatar
jfgimenez
Site Admin
Posts: 5568
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xailer 5.03 .... Compile error on all projects??

Postby jfgimenez » Fri Mar 30, 2018 12:22 am

Hi Chris,

that error is caused by a wrong version of MinGW. You probably has another MinGW version in your path, or you've updated Xailer ontop an old Xailer version without updating Harbour.

Please, delete your hb32 folder which is in Xailer folder, and download and install our Harbour distro again (http://www2.xailer.com/download/?file=2). Also be sure you have not another MinGW in your path.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
ChrisGillard
Posts: 384
Joined: Tue May 01, 2007 5:49 pm

Re: Xailer 5.03 .... Compile error on all projects??

Postby ChrisGillard » Fri Mar 30, 2018 7:49 am

Hi Jose,

Thank you very much for the very quick reply.

I will examine my pathing and reinstall your Harbour distro.

I will report back in a couple of hours.

Thank you.

Chris
ChrisGillard
Posts: 384
Joined: Tue May 01, 2007 5:49 pm

Re: Xailer 5.03 .... Compile error on all projects??

Postby ChrisGillard » Fri Mar 30, 2018 10:03 am

Hi Jose,

I did what you say ...

Deleted hb32 in \xailer5

Removed all reference to mingw in Environment vars

Install from your link

Xailer Tools paths look OK.

Environment paths .... new c:\xailer5\hb32\comp\mingw\bin at top ... as it should be, probably.

Still get error ...

Now.png
Now.png (18.86 KiB) Viewed 600 times


The path in the error box does say its looking in the right place!!

I'm very stuck so any help possible would be good.

Thank you.

Chris
User avatar
ignacio
Site Admin
Posts: 8409
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: Xailer 5.03 .... Compile error on all projects??

Postby ignacio » Fri Mar 30, 2018 12:13 pm

Hello Crhis,

I suggest you temporary rename any MinGW directory except the one you should use.

Regards,
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
ChrisGillard
Posts: 384
Joined: Tue May 01, 2007 5:49 pm

Re: Xailer 5.03 .... Compile error on all projects??

Postby ChrisGillard » Fri Mar 30, 2018 12:57 pm

Hi Ignacio,

Thank you both for helping with this.

I have installed Xailer5 on my laptop as a Demo and I am doing better for now. I am happy to have the program run under the IDE at the moment as its me that needs to use it to get a job done for a Customer.

In UK it is 'Easter Friday' which is a 'Bank Holiday' where most people are not working today .... are you working today in Spain? If you are I might even reinstall Xailer5 on this Desktop PC and start again.

What do you think?

Chris
User avatar
jfgimenez
Site Admin
Posts: 5568
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Xailer 5.03 .... Compile error on all projects??

Postby jfgimenez » Fri Mar 30, 2018 1:14 pm

Chris,

yes, it's holiday here in Spain too ;-)

Perhaps you've downloaded a wrong Harbour. Please, download it from the button "Download the file" at the URL I've sent before, not from the green arrow which is at the bottom. The filename must be "harbour32setup4.exe". Also, be sure all paths are right in the IDE's options dialog.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
ChrisGillard
Posts: 384
Joined: Tue May 01, 2007 5:49 pm

Re: Xailer 5.03 .... Compile error on all projects??

Postby ChrisGillard » Fri Mar 30, 2018 3:17 pm

Hi Jose & Ignacio,

Well if it is a holiday in Spain, I think you should do that!

I can compile in demo mode from my laptop and use it in the IDE which will rescue my day.

I can confirm that I have used the .....Harbour32Setup4.exe file.

My plan at some stage will be to Uninstall Xailer on my PC and start again .... but not today or for a few days.

Thank you very much for you help last night and today.

Much appreciated.

Regards

Chris
User avatar
orangesocks
Posts: 52
Joined: Thu May 05, 2011 3:28 pm

Re: Xailer 5.03 .... Compile error on all projects??

Postby orangesocks » Wed May 16, 2018 1:04 pm

Hi Chris,
I got the same error here and after reading here https://stackoverflow.com/questions/726 ... ed#7264538, I found out that a copy of libiconv-2.dll was in my C:\Windows\sysWOW64 folder ( I'm on Win10 64bit).
After removing the dll the error disappeared.

HTH Giuseppe

Return to “English”

cron