In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Errors after last Xailer Update

Xailer professional forum in English
User avatar
emeasoft
Posts: 1062
Joined: Wed Apr 01, 2009 4:12 pm
Location: emeasoft
Contact:

Errors after last Xailer Update

Postby emeasoft » Mon Sep 08, 2014 2:31 pm

Hello Xailers,
After the last Xailer update, the following error (error2) started to happen on the errorsys...
Right after error 1, the error 2 popup about 5 times...
Error 1:

This first error seem to be happening because now the oNextCtl param from the FormChangeFocus() is the form itself, is this right?
In this method we check the Cargo from the oNextCtl, and now it is giving this error when it first pass this method...
Error 2:

Does anybody knows what is causing all this?
TIA,
Juliano

Attached files error1_log.txt (1.5 KB)Â
User avatar
emeasoft
Posts: 1062
Joined: Wed Apr 01, 2009 4:12 pm
Location: emeasoft
Contact:

Errors after last Xailer Update

Postby emeasoft » Mon Sep 08, 2014 4:23 pm

Here goes an example of the error.
Note how many recursive error pops up after the main error...
Thanks

Attached files Error.zip (2.9 KB)Â
User avatar
ignacio
Site Admin
Posts: 8546
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Errors after last Xailer Update

Postby ignacio » Mon Sep 08, 2014 5:27 pm

Hello Juliano,
As I can see the problem only arises when compiling with Borland. We are working on it. I keep you informed. Sorry for any inconvenience.
Best regards,
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
ignacio
Site Admin
Posts: 8546
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Errors after last Xailer Update

Postby ignacio » Mon Sep 08, 2014 6:18 pm

Dear Juliano,
After revising in deep your code we believe the problem is on your side because the first time the method is called oNextCtl points to TForm1. Your code should be something like this:
METHOD FormChangeFocus( oSender, oPrevCtl, oNextCtl ) CLASS TForm1

WITH OBJECT oNextCtl
IF :IsKindOf( "TEdit" ) .or. :IsKindOf( "TRadioMenu" )
::dFocus := oNextCtl
IF Valtype( :Cargo ) = "C" .AND. :Cargo $ "oEdit4"
MsgInfo( "oEdit4!!" )
ENDIF
ENDIF
END WITH

RETURN Nil

Notes about the code:
Use IsKindOf() instead of classname, that way all descedants of TEdit are included. Even the user controls that you can easily create with this new version.
BTW, there is also a recursive error problem when a RTE message is triggered in which we are still working.
Regards,
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
emeasoft
Posts: 1062
Joined: Wed Apr 01, 2009 4:12 pm
Location: emeasoft
Contact:

Errors after last Xailer Update

Postby emeasoft » Tue Sep 09, 2014 2:25 pm

Hello Ignacio!
Thanks for the help.
We have updated to the new version, the F12 error has been fixed, but the recursive error message still happens...
Any ETA to a solution?
Thanks,
Juliano
User avatar
emeasoft
Posts: 1062
Joined: Wed Apr 01, 2009 4:12 pm
Location: emeasoft
Contact:

Errors after last Xailer Update

Postby emeasoft » Tue Sep 09, 2014 7:48 pm

Hello !
Seeing the fact that some errors on Xailer version 3.3.1 are preventing
us to keep up our work, we are downgrading to version 3.2.0 until it has been solved.
Thanks
Mário Angelini
User avatar
ignacio
Site Admin
Posts: 8546
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Errors after last Xailer Update

Postby ignacio » Tue Sep 09, 2014 8:19 pm

Hello,
We decided to no fix the recursivity problem when triggering a RTE error since it only arises in exceptional circumstances when the error origin belongs from a change of focus operation, because the Errorsys dialog also change the focus and that is way there is such recursivity.
We could fix it putting some IF..ENDIF code when the dialog is a errorsys dialog. But all this code is written en 'C' and is extremely fast. We decide to leave it as is in order to maintain the code simple and fast.
Regards,
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Errors after last Xailer Update

Postby jfgimenez » Tue Sep 09, 2014 9:45 pm

Mario,
> Hello !
> Seeing the fact that some errors on Xailer version 3.3.1 are
> preventing
> us to keep up our work, we are downgrading to version 3.2.0
Sad to read this :-(
> until it has been solved.
What are those errors? IFAIK, the problem reported in this same thread
is an error in your code. BTW, I can asure you that the above code
causes exactly the same error in any Xailer version, not 3.3 only.
And the related recursive error, as Ignacio has said, only hapens if you
have an error in your code in a change focus event. When the error
message is shown, a new focus change occurs, causing another error from
the errorsys itself. After we have study it in deep, we decided to not
change anything, since it'd only add complexity to the code. Anyway, the
error is shown correctly for the first time, and when you fix your code,
both the error and the recursivity vanishes.
However, please, tell us what errors have you detected in order to fix
it ASAP. TIA for your feedback.
Regards,
Jose F. Gimenez
http://www.xailer.com
http://www.xailer.info
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
User avatar
emeasoft
Posts: 1062
Joined: Wed Apr 01, 2009 4:12 pm
Location: emeasoft
Contact:

Errors after last Xailer Update

Postby emeasoft » Tue Sep 09, 2014 11:10 pm

Gimenez:
In version 3.2 it worked differently.
We changed our lines of code and is
all resolved.
Thank you.
Mário angelini
User avatar
jfgimenez
Site Admin
Posts: 5620
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Errors after last Xailer Update

Postby jfgimenez » Wed Sep 10, 2014 9:38 am

Mario,
> In version 3.2 it worked differently.
I don't think so. It should be another different issue, not the problem
you showed in the example above. That sample fails in all Xailer
versions. Please, study it, and you'll see that the error ocurrs at this
line:
IF ::dFocus:Cargo$"oEdit4"
just because ::dFocus has not been assigned yet, and its value is NIL at
this point (the first time the event is fired). That's all. It's not
related to Xailer 3.3.
> We changed our lines of code and is all resolved. Thank you.
Glad to see you've solved the problem.
BTW, many times it's very easy to locate the problem by using the
integrated debugger and executing the program step by step. Please, test
it, and you'll be greatly surprised ;-)
Regards,
Jose F. Gimenez
http://www.xailer.com
http://www.xailer.info
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info

Return to “English”