Page 1 of 1

Sobre TDbfBrowse

Posted: Fri Dec 21, 2007 1:10 am
by Hugo Navarro
Buen Dia a Todos
Tengo un problema con un objeto: TDbfBrowse
lanso la siguiente instruccion:
::o1DbfBrowse:Append()
y no me crea el nuevo registro.
lo lanso desde un click de un boton ya se con un metodo o con un bloque de
codigo.
y el resultado es Falso, no me crea el registro Nuevo.
Saludos y Gracias ... Feliz Navidad y Mejor Año Para todos ...

Sobre TDbfBrowse

Posted: Fri Dec 21, 2007 2:30 pm
by jrcpoli-quitar
Saludos:
Si el TdbfBrowse lo vas a asociar a un TDataSet es mejor que utilices
TDBBrowse ya que puedes asociarle directamente el TDataSet y los campos
de la base de datos luego solo tendrí­as que poner un método asociado al
botón que hiciera el alta, llamando a otro formulario, o directamente en
el TDBBrowse, te aconsejo que mires los ejemplos que vienen en el
directorio Samples y dentro del mismo la carpeta
C:XailerSamplesBrowses y C:XailerSamplesDataControls, cambia las
rutas en el explorador a donde tengas instalado Xailer en tu ordenador.
Ya sabes que para cambiar un objeto por otro solo tienes que darle con
el botón derecho del ratón encima del nombre del objeto que quieres
cambiar en el inspector de objetos y seleccionar en el menú cambiar.
José Ramón Castro.
Hugo Navarro escribió:
> Buen Dia a Todos
>
> Tengo un problema con un objeto: TDbfBrowse
> lanso la siguiente instruccion:
> ::o1DbfBrowse:Append()
>
> y no me crea el nuevo registro.
> lo lanso desde un click de un boton ya se con un metodo o con un bloque de
> codigo.
> y el resultado es Falso, no me crea el registro Nuevo.
>
> Saludos y Gracias ... Feliz Navidad y Mejor Año Para todos ...
>